Tehnografi.com - Технологические новости, обзоры и советы

Разработчикам необходимо обновить приложения WatchOS 1, чтобы улучшить совместимость с будущими версиями

AppleБета-версия watchOS 1 4.3.1 включает в себя предупреждающее сообщение для пользователей об обновлении связанных приложений. В сообщении говорится, что поддержка приложений watchOS 1 скоро прекратится.

В качестве решения в нем четко указано, что разработчикам соответствующих приложений необходимо предоставлять обновления для улучшения совместимости. Это интересный способ для Apple передать сообщение.

Нажав «ОК» после появления сообщения, вы сможете открыть приложение в обычном режиме. Это позволяет сделать вывод, что бета-версия 4.3.1 совместима со старым программным обеспечением Watch.

В ноябре прошлого года, Apple уведомил разработчиков о том, что не будет принимать заявки на приложения watchOS 1 в 2018 году. Начиная с 1 апреля они должны использовать комплект разработки watchOS 2 или более поздней версии для создания обновлений существующих приложений. С другой стороны, новые приложения должны быть написаны как минимум на watchOS 4 или более поздней версии.

Сейчас Apple Watch начинает набирать популярность, но крупные производители приложений «отказались от разработки приложений для этой платформы». Instagram начали в этом месяце с закрытия своего приложения вместо того, чтобы пересобрать его с помощью watchOS 4 SDK.

Мы следим за тем, что Apple представляет следующий продукт для носимых устройств. Следите за обновлениями!